Skip to content
Laskyr

Plugins · duracelltomi-google-tag-manager · data as of 2026-11-01

Is GTM4WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.6)

As of 2026-11-01. 3 issues are on record for older versions; version 1.22.4 or newer fixes all of them that state a fix.

Latest version
2.0.6
Last updated
2026-10-12
Active installs
700,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Advanced tag management for WordPress with Google Tag Manager — by Thomas Geiger

What to do

  1. Update to the latest version (2.0.6). Anything older than 1.22.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get duracelltomi-google-tag-manager --field=version shows what you run; wp plugin update duracelltomi-google-tag-manager updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-16597 · published 2026-07-29

Stored cross-site scripting (XSS) in GTM4WP (1.22.3 and older)

Affected
1.22.3 and older
Fixed in
1.22.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GTM4WP – A Google Tag Manager (GTM) plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WooCommerce Billing Fields in all versions up to, and including, 1.22.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the GTM4WP WooCommerce order data integration option (GTM4WP_OPTION_INTEGRATE_WCORDERDATA) to be enabled, and is exploited by placing a guest checkout order with a JavaScript payload in a WooCommerce billing field such as the billing first name.

NVD CVE-2026-16597Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2022-1961 · published 2022-06-13

Stored cross-site scripting (XSS) in GTM4WP (1.15.1 and older)

Affected
1.15.1 and older
Fixed in
1.15.2 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Google Tag Manager for WordPress (GTM4WP) plugin is vulnerable to Stored Cross-Site Scripting due to insufficient escaping via the `gtm4wp-options[scroller-contentid]` parameter found in the `~/public/frontend.php` file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.15.1. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.

NVD CVE-2022-1961Wordfence advisoryCode change (fix)wordpress.orggist.github.comWordfence advisory

medium 6.1 CVE-2022-1707 · published 2022-06-13

Reflected cross-site scripting (XSS) in GTM4WP (1.15 and older)

Affected
1.15 and older
Fixed in
1.15.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.

NVD CVE-2022-1707Wordfence advisorygithub.comgithub.comWordfence advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GTM4WP vulnerability status badge
<a href="https://laskyr.com/plugins/duracelltomi-google-tag-manager"><img src="https://laskyr.com/plugins/duracelltomi-google-tag-manager/badge.svg" alt="GTM4WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit