Plugins · duplicate-wp-page-post · data as of 2026-11-04
Is Duplicate Page and Post safe? Known vulnerabilities and latest version
- Latest version
- 2.9.8
- Last updated
- 2026-09-25
- Active installs
- 70,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Duplicate pages, posts and custom post types with a single click. — by Arjun Thakur
What to do
- Update to the latest version (2.9.8). Anything older than 2.9.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get duplicate-wp-page-post --field=version shows what you run; wp plugin update duplicate-wp-page-post updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.5 CVE-2026-49046 · published 2026-05-27
SQL injection in Duplicate Page and Post (2.9.5 and older)
- Affected
- 2.9.5 and older
- Fixed in
- 2.9.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Arjun Thakur Duplicate Page and Post allows Blind SQL Injection. This issue affects Duplicate Page and Post: from n/a through 2.9.5.
medium 6.5 CVE-2025-6189 · published 2025-09-10
SQL injection in Duplicate Page and Post (2.9.5 and older)
- Affected
- 2.9.5 and older
- Fixed in
- 2.9.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Duplicate Page and Post plugin for WordPress is vulnerable to time-based SQL Injection via the ‘meta_key’ parameter in all versions up to, and including, 2.9.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2025-6189Wordfence advisorywordpress.orgPlugin source
medium 4.8 CVE-2022-2152 · published 2022-08-15
Cross-site scripting (XSS) in Duplicate Page and Post (older than 2.8)
- Affected
- older than 2.8
- Fixed in
- 2.8
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Duplicate Page and Post WordPress plugin before 2.8 does not sanitise and escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Recent activity
- 2026-09-25 — latest release on wordpress.org (2.9.8).
- 2026-05-27 — SQL injection disclosed (CVE-2026-49046), fixed in 2.9.6.
- 2025-09-10 — SQL injection disclosed (CVE-2025-6189), fixed in 2.9.6.
- 2022-08-15 — Cross-site scripting (XSS) disclosed (CVE-2022-2152), fixed in 2.8.
Get an email when Duplicate Page and Post has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Duplicate Page and Post (duplicate-wp-page-post) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/duplicate-wp-page-post (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/duplicate-wp-page-post"><img src="https://laskyr.com/plugins/duplicate-wp-page-post/badge.svg" alt="Duplicate Page and Post vulnerability status"></a>