Skip to content
Laskyr

Plugins · duplicate-post · data as of 2026-11-01

Is Yoast Duplicate Post safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.7)

As of 2026-11-01. 3 issues are on record for older versions; version 4.6 or newer fixes all of them that state a fix.

Latest version
4.7
Last updated
2026-10-06
Active installs
3+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The go-to tool for cloning posts and pages, including the powerful Rewrite & Republish feature. — by Yoast

What to do

  1. Update to the latest version (4.7). Anything older than 4.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get duplicate-post --field=version shows what you run; wp plugin update duplicate-post updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-1217 · published 2026-03-18

Missing authorization check in Yoast Duplicate Post (4.5 and older)

Affected
4.5 and older
Fixed in
4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.

NVD CVE-2026-1217Wordfence advisoryPlugin source

medium 6.1 CVE-2014-10378 · published 2019-08-21

Cross-site scripting (XSS) in Yoast Duplicate Post (older than 2.6)

Affected
older than 2.6
Fixed in
2.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The duplicate-post plugin before 2.6 for WordPress has XSS.

NVD CVE-2014-10378wordpress.org

critical 9.8 CVE-2014-10379 · published 2019-08-21

SQL injection in Yoast Duplicate Post (older than 2.6)

Affected
older than 2.6
Fixed in
2.6
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The duplicate-post plugin before 2.6 for WordPress has SQL injection.

NVD CVE-2014-10379wordpress.org

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Yoast Duplicate Post vulnerability status badge
<a href="https://laskyr.com/plugins/duplicate-post"><img src="https://laskyr.com/plugins/duplicate-post/badge.svg" alt="Yoast Duplicate Post vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit