Plugins · duplicate-page · data as of 2026-11-01
Is Duplicate Page safe? Known vulnerabilities and latest version
- Latest version
- 4.5.9
- Last updated
- 2026-05-08
- Active installs
- 3+ million
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Duplicate Posts, Pages and Custom Posts easily using single click — by mndpsingh287
What to do
- Update to the latest version (4.5.9). Anything older than 4.4.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get duplicate-page --field=version shows what you run; wp plugin update duplicate-page updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.8 CVE-2021-24681 · published 2021-10-11
Stored cross-site scripting (XSS) in Duplicate Page (4.4.2 to 4.4.2)
- Affected
- 4.4.2 to 4.4.2
- Fixed in
- 4.4.9 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Duplicate Page WordPress plugin through 4.4.2 does not sanitise or escape the Duplicate Post Suffix settings before outputting it, which could allow high privilege users to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Recent activity
- 2026-05-08 — latest release on wordpress.org (4.5.9).
- 2021-10-11 — Stored cross-site scripting (XSS) disclosed (CVE-2021-24681), fixed in 4.4.9.
Get an email when Duplicate Page has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Duplicate Page (duplicate-page) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/duplicate-page (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/duplicate-page"><img src="https://laskyr.com/plugins/duplicate-page/badge.svg" alt="Duplicate Page vulnerability status"></a>