Plugins · duitku-social-payment-gateway · data as of 2026-11-04
Is Duitku Payment Gateway safe? Known vulnerabilities and latest version
- Latest version
- 2.11.14
- Last updated
- 2026-03-03
- Active installs
- 700+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11
Do you want the best solution to accept Credit Cards, e-wallet, and Various Bank Transfers on your website? Our Payment Gateway for WooCommerce plugin … — by rayhanduitku
What to do
- There is no fixed version yet. If you can live without Duitku Payment Gateway for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get duitku-social-payment-gateway --field=version shows what you run; wp plugin update duitku-social-payment-gateway updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 affects latest 2.11.14 CVE-2026-32468 · published 2026-08-18
Information disclosure in Duitku Payment Gateway (2.11.14 and older)
- Affected
- 2.11.14 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Sensitive Data Exposure in Duitku Payment Gateway <= 2.11.14 versions.
medium 5.3 CVE-2024-0631 · published 2024-03-13
Missing authorization check in Duitku Payment Gateway (2.11.6 and older)
- Affected
- 2.11.6 and older
- Fixed in
- 2.11.10 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Duitku Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the check_duitku_response function in all versions up to, and including, 2.11.6. This makes it possible for unauthenticated attackers to change the payment status of orders to failed.
NVD CVE-2024-0631Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-03-03 — latest release on wordpress.org (2.11.14).
- 2026-08-18 — Information disclosure disclosed (CVE-2026-32468), no fix listed yet.
- 2024-03-13 — Missing authorization check disclosed (CVE-2024-0631), fixed in 2.11.10.
Get an email when Duitku Payment Gateway has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Duitku Payment Gateway (duitku-social-payment-gateway) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/duitku-social-payment-gateway (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/duitku-social-payment-gateway"><img src="https://laskyr.com/plugins/duitku-social-payment-gateway/badge.svg" alt="Duitku Payment Gateway vulnerability status"></a>