Skip to content
Laskyr

Plugins · dsgvo-leaflet-map · data as of 2026-11-04

Is DSGVO snippet for Leaflet Map and its Extensions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0)

As of 2026-11-04. 1 issue is on record for older versions; version 3.2 or newer fixes all of them that state a fix.

Latest version
4.0
Last updated
2026-08-15
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Respect the DSGVO / GDPR when you use Leaflet Map and Extensions for Leaflet Map. — by hupe13

What to do

  1. Update to the latest version (4.0). Anything older than 3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dsgvo-leaflet-map --field=version shows what you run; wp plugin update dsgvo-leaflet-map updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4389 · published 2026-03-26

Stored cross-site scripting (XSS) in DSGVO snippet for Leaflet Map and its Extensions (3.1 and older)

Affected
3.1 and older
Fixed in
3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The DSGVO snippet for Leaflet Map and its Extensions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `leafext-cookie-time` and `leafext-delete-cookie` shortcodes in all versions up to, and including, 3.1. This is due to insufficient input sanitization and output escaping on user supplied attributes (`unset`, `before`, `after`). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4389Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DSGVO snippet for Leaflet Map and its Extensions vulnerability status badge
<a href="https://laskyr.com/plugins/dsgvo-leaflet-map"><img src="https://laskyr.com/plugins/dsgvo-leaflet-map/badge.svg" alt="DSGVO snippet for Leaflet Map and its Extensions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit