Skip to content
Laskyr

Plugins · download-plugins-dashboard · data as of 2026-11-04

Is Download Plugins and Themes in ZIP from Dashbo… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.0)

As of 2026-11-04. 4 issues are on record for older versions; version 1.9.7 or newer fixes all of them that state a fix.

Latest version
2.1.0
Last updated
2026-07-24
Active installs
30,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.0.0+

Download installed plugins and themes in ZIP files directly from your WordPress admin dashboard, download any or all without FTP or cPanel access. — by WPFactory

What to do

  1. Update to the latest version (2.1.0). Anything older than 1.9.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get download-plugins-dashboard --field=version shows what you run; wp plugin update download-plugins-dashboard updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-14399 · published 2025-12-17

Cross-site request forgery (CSRF) in Download Plugins and Themes in ZIP from Dashbo… (1.9.6 and older)

Affected
1.9.6 and older
Fixed in
1.9.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Download Plugins and Themes in ZIP from Dashboard plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.6. This is due to missing or incorrect nonce validation on the download_plugin_bulk and download_theme_bulk functions. This makes it possible for unauthenticated attackers to archive all the sites plugins and themes and place them in the `wp-content/uploads/` directory via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-14399Wordfence advisoryCode change (fix)

medium 6.1 CVE-2024-9232 · published 2024-10-11

Reflected cross-site scripting (XSS) in Download Plugins and Themes in ZIP from Dashbo… (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Download Plugins and Themes in ZIP from Dashboard plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.9.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9232Wordfence advisoryCode change (fix)Plugin source

medium 4.2 CVE-2024-7501 · published 2024-08-16

Cross-site request forgery (CSRF) in Download Plugins and Themes in ZIP from Dashbo… (1.8.7 and older)

Affected
1.8.7 and older
Fixed in
1.8.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Download Plugins and Themes in ZIP from Dashboard plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.8.7. This is due to missing or incorrect nonce validation on the download_theme() function. This makes it possible for unauthenticated attackers to download arbitrary themes from the website via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. In versions prior to 1.8.6 it was possible to download the entire sites files.

NVD CVE-2024-7501Wordfence advisoryCode change (fix)

medium 6.1 CVE-2019-17239 · published 2019-10-07

Stored cross-site scripting (XSS) in Download Plugins and Themes in ZIP from Dashbo… (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.6.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

includes/settings/class-alg-download-plugins-settings.php in the download-plugins-dashboard plugin through 1.5.0 for WordPress has multiple unauthenticated stored XSS issues.

NVD CVE-2019-17239wordpress.orgwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Download Plugins and Themes in ZIP from Dashbo… vulnerability status badge
<a href="https://laskyr.com/plugins/download-plugins-dashboard"><img src="https://laskyr.com/plugins/download-plugins-dashboard/badge.svg" alt="Download Plugins and Themes in ZIP from Dashbo… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit