Skip to content
Laskyr

Plugins · download-attachments · data as of 2026-11-04

Is Download Attachments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.1)

As of 2026-11-04. 4 issues are on record for older versions; version 1.4.1 or newer fixes all of them that state a fix.

Latest version
1.4.1
Last updated
2026-05-26
Active installs
8,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0.0+

Download Attachments is a new approach to managing downloads in WordPress. It allows you to easily add and display download links in any post or page. — by dFactory

What to do

  1. Update to the latest version (1.4.1). Anything older than 1.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get download-attachments --field=version shows what you run; wp plugin update download-attachments updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-39616 · published 2026-04-08

Missing authorization check in Download Attachments (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in dFactory Download Attachments download-attachments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Download Attachments: from n/a through <= 1.4.0.

NVD CVE-2026-39616Patchstack advisory

medium 5.3 CVE-2025-49995 · published 2025-06-20

Missing authorization check in Download Attachments (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in dFactory Download Attachments download-attachments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Download Attachments: from n/a through <= 1.3.1.

NVD CVE-2025-49995Patchstack advisory

medium 6.4 CVE-2024-3230 · published 2024-06-04

Stored cross-site scripting (XSS) in Download Attachments (1.3 and older)

Affected
1.3 and older
Fixed in
1.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Download Attachments plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'download-attachments' shortcode in all versions up to, and including, 1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-3230Wordfence advisoryCode change (fix)wordpress.org

medium 5.4 CVE-2023-0076 · published 2023-03-06

Stored cross-site scripting (XSS) in Download Attachments (older than 1.3)

Affected
older than 1.3
Fixed in
1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Download Attachments WordPress plugin before 1.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2023-0076WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Download Attachments vulnerability status badge
<a href="https://laskyr.com/plugins/download-attachments"><img src="https://laskyr.com/plugins/download-attachments/badge.svg" alt="Download Attachments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit