Skip to content
Laskyr

Plugins · doublescale · data as of 2026-11-04

Is DoubleScale CRM safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.6.0 or newer fixes all of them that state a fix.

Latest version
1.9.3
Last updated
2026-11-04
Active installs
70+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

All-in-one WordPress CRM: email, SMS and WhatsApp marketing, newsletters, sales pipeline, booking, helpdesk, MCP and automations. A self-hosted CRM. — by DoubleScale

What to do

  1. Update to the latest version (1.9.3). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get doublescale --field=version shows what you run; wp plugin update doublescale updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-111311 · published 2026-10-16

Arbitrary file upload in DoubleScale CRM (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.6.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The DoubleScale | All-in-One CRM – Sales, Multi-Channel Marketing, Newsletter, Booking, Helpdesk, Automation, MCP & More plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.5.1 via the store_upload function. This is due to a fail-open extension allow-list in extension_is_allowed() that returns true when wp_check_filetype() yields an empty type for unrecognized extensions such as .php, combined with magic-byte-only MIME detection and no capability check beyond is_user_logged_in(). This makes it possible for authenticated attackers, with subscriber-level access and above, to upload files that may be executable, which makes remote code execution possible. Exploitation requires the Helpdesk module to be enabled, as the vulnerable REST endpoint is only registered when that module is active.

NVD CVE-2026-111311Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DoubleScale CRM vulnerability status badge
<a href="https://laskyr.com/plugins/doublescale"><img src="https://laskyr.com/plugins/doublescale/badge.svg" alt="DoubleScale CRM vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit