Skip to content
Laskyr

Plugins · doubledome-resource-link-library · data as of 2026-11-04

Is Resource Library for Logged In Users safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6)

As of 2026-11-04. 1 issue is on record for older versions; version 1.6 or newer fixes all of them that state a fix.

Latest version
1.6
Last updated
2025-12-17
Active installs
20+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

This Resource Library, Link Library, PDF Library, Document Library, and Video Library plugin enables admins to organize and store categorized resource … — by doubledome

What to do

  1. Update to the latest version (1.6). Anything older than 1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get doubledome-resource-link-library --field=version shows what you run; wp plugin update doubledome-resource-link-library updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-14354 · published 2025-12-12

Cross-site request forgery (CSRF) in Resource Library for Logged In Users (1.5 and older)

Affected
1.5 and older
Fixed in
1.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Resource Library for Logged In Users plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.5. This is due to missing nonce validation on multiple administrative functions. This makes it possible for unauthenticated attackers to perform various unauthorized actions including creating, editing, and deleting resources and categories via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-14354Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Resource Library for Logged In Users vulnerability status badge
<a href="https://laskyr.com/plugins/doubledome-resource-link-library"><img src="https://laskyr.com/plugins/doubledome-resource-link-library/badge.svg" alt="Resource Library for Logged In Users vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit