Skip to content
Laskyr

Plugins · doofinder-for-woocommerce · data as of 2026-11-04

Is DOOFINDER Search and Discovery for WP & WooCom… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.17.3)

As of 2026-11-04. 5 issues are on record for older versions; version 2.10.14 or newer fixes all of them that state a fix.

Latest version
2.17.3
Last updated
2026-10-29
Active installs
2,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

This plugin integrates the Doofinder search service with your WordPress site. — by Doofinder

What to do

  1. Update to the latest version (2.17.3). Anything older than 2.10.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get doofinder-for-woocommerce --field=version shows what you run; wp plugin update doofinder-for-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-39542 · published 2026-04-08

Information disclosure in DOOFINDER Search and Discovery for WP & WooCom… (2.10.13 and older)

Affected
2.10.13 and older
Fixed in
2.10.14
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Doofinder Doofinder for WooCommerce doofinder-for-woocommerce allows Retrieve Embedded Sensitive Data.This issue affects Doofinder for WooCommerce: from n/a through <= 2.10.13.

NVD CVE-2026-39542Patchstack advisory

medium 4.8 CVE-2024-25596 · published 2024-03-15

Stored cross-site scripting (XSS) in DOOFINDER Search and Discovery for WP & WooCom… (2.1.8 and older)

Affected
2.1.8 and older
Fixed in
2.1.9
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Doofinder Doofinder for WooCommerce allows Stored XSS.This issue affects Doofinder for WooCommerce: from n/a through 2.1.8.

NVD CVE-2024-25596Patchstack advisory

medium 6.5 CVE-2023-51678 · published 2024-01-05

Cross-site request forgery (CSRF) in DOOFINDER Search and Discovery for WP & WooCom… (2.0.33 and older)

Affected
2.0.33 and older
Fixed in
2.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Doofinder Doofinder WP & WooCommerce Search.This issue affects Doofinder WP & WooCommerce Search: from n/a through 2.0.33.

NVD CVE-2023-51678Patchstack advisory

medium 6.1 CVE-2023-40602 · published 2023-12-19

Open redirect in DOOFINDER Search and Discovery for WP & WooCom… (1.5.49 and older)

Affected
1.5.49 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Doofinder Doofinder WP & WooCommerce Search.This issue affects Doofinder WP & WooCommerce Search: from n/a through 1.5.49.

NVD CVE-2023-40602Patchstack advisory

medium 6.1 CVE-2023-49185 · published 2023-12-15

Reflected cross-site scripting (XSS) in DOOFINDER Search and Discovery for WP & WooCom… (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Doofinder Doofinder WP & WooCommerce Search allows Reflected XSS.This issue affects Doofinder WP & WooCommerce Search: from n/a through 2.1.7.

NVD CVE-2023-49185Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DOOFINDER Search and Discovery for WP & WooCom… vulnerability status badge
<a href="https://laskyr.com/plugins/doofinder-for-woocommerce"><img src="https://laskyr.com/plugins/doofinder-for-woocommerce/badge.svg" alt="DOOFINDER Search and Discovery for WP & WooCom… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit