Skip to content
Laskyr

Plugins · dologin · data as of 2026-11-04

Is DoLogin Security safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.1.3)

As of 2026-11-04. 5 issues are on record for older versions; version 4.4 or newer fixes all of them that state a fix.

Latest version
5.1.3
Last updated
2026-10-13
Active installs
7,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Login security: KeyLockr SSO scan login, 2FA, passwordless login, Cloudflare Turnstile, GeoLocation/IP limits, whitelist and blacklist. — by WPDO

What to do

  1. Update to the latest version (5.1.3). Anything older than 4.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dologin --field=version shows what you run; wp plugin update dologin updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-14495 · published 2026-07-08

Authentication bypass in DoLogin Security (4.3 and older)

Affected
4.3 and older
Fixed in
4.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The DoLogin Security plugin for WordPress is vulnerable to Authentication Bypass via Insufficient Randomness in all versions up to, and including, 4.3. The vulnerability exists because `dologin\s::rrand()` seeds the Mersenne Twister with `mt_srand((double) microtime() * 1000000)` — discarding the integer-seconds component of `microtime()` and constraining the seed to a range of approximately 10^6 values (~20 bits of entropy) — after which every character of the 32-character magic-link token is drawn sequentially with `mt_rand()`, making the entire token a deterministic function of that seed. Because `Pswdless::try_login()` is registered on the unauthenticated `init` hook, resolves the target account by the auto-increment numeric ID embedded in the `?dologin=<id>.<hash>` parameter, performs the hash comparison using a non-constant-time `!=` operator, and then calls `wp_set_auth_cookie()` directly — never passing through `wp_authenticate()` and therefore never triggering the plugin's own `Auth::_has_login_err()` lockout — an unauthenticated attacker can brute-force the ~10^6-candidate seed space to reconstruct an active passwordless login token and authenticate as any targeted user, including administrators, without a password. Exploitation requires that a valid, unexpired passwordless login link (active for up to 7 days) exists for the target account at the time of the attack, and that the numeric link ID is known or guessable from the auto-increment primary key.

NVD CVE-2026-14495Wordfence advisoryPlugin source

medium 5.3 CVE-2023-46608 · published 2025-01-02

Missing authorization check in DoLogin Security (3.7.1 and older)

Affected
3.7.1 and older
Fixed in
3.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPDO DoLogin Security dologin allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects DoLogin Security: from n/a through <= 3.7.1.

NVD CVE-2023-46608Patchstack advisory

medium 6.5 CVE-2023-4800 · published 2023-10-16

Security issue in DoLogin Security (older than 3.7.1)

Affected
older than 3.7.1
Fixed in
3.7.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The DoLogin Security WordPress plugin before 3.7.1 does not restrict the access of a widget that shows the IPs of failed logins to low privileged users.

NVD CVE-2023-4800WPScan advisory

medium 6.1 CVE-2023-4549 · published 2023-09-25

Stored cross-site scripting (XSS) in DoLogin Security (older than 3.7)

Affected
older than 3.7
Fixed in
3.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The DoLogin Security WordPress plugin before 3.7 does not properly sanitize IP addresses coming from the X-Forwarded-For header, which can be used by attackers to conduct Stored XSS attacks via WordPress' login form.

NVD CVE-2023-4549WPScan advisory

medium 5.3 CVE-2023-4631 · published 2023-09-25

Security issue in DoLogin Security (older than 3.7)

Affected
older than 3.7
Fixed in
3.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The DoLogin Security WordPress plugin before 3.7 uses headers such as the X-Forwarded-For to retrieve the IP address of the request, which could lead to IP spoofing.

NVD CVE-2023-4631WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DoLogin Security vulnerability status badge
<a href="https://laskyr.com/plugins/dologin"><img src="https://laskyr.com/plugins/dologin/badge.svg" alt="DoLogin Security vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit