Skip to content
Laskyr

Plugins · doliconnect · data as of 2026-11-04

Is Doliconnect safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (10.7.9)

As of 2026-11-04. 2 issues are on record for older versions; version 9.6.2 or newer fixes all of them that state a fix.

Latest version
10.7.9
Last updated
2026-10-10
Active installs
30+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.2 · PHP 8.1+

This plugin interfaces your Dolibarr with your WordPress. — by ptibogxiv

What to do

  1. Update to the latest version (10.7.9). Anything older than 9.6.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get doliconnect --field=version shows what you run; wp plugin update doliconnect updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2025-53574 · published 2025-11-06

Reflected cross-site scripting (XSS) in Doliconnect (9.3.2 and older)

Affected
9.3.2 and older
Fixed in
9.4.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ptibogxiv Doliconnect doliconnect allows Reflected XSS.This issue affects Doliconnect: from n/a through <= 9.3.2.

NVD CVE-2025-53574Patchstack advisory

high 7.1 CVE-2025-58690 · published 2025-09-22

Cross-site request forgery (CSRF) in Doliconnect (9.5.7 and older)

Affected
9.5.7 and older
Fixed in
9.6.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in ptibogxiv Doliconnect doliconnect allows Stored XSS.This issue affects Doliconnect: from n/a through <= 9.5.7.

NVD CVE-2025-58690Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Doliconnect vulnerability status badge
<a href="https://laskyr.com/plugins/doliconnect"><img src="https://laskyr.com/plugins/doliconnect/badge.svg" alt="Doliconnect vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit