Plugins · document-library-lite · data as of 2026-11-04
Is Document Library Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.3.2
- Last updated
- 2026-10-28
- Active installs
- 4,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Create a WordPress document library to manage, search and download files. — by Barn2 Plugins
What to do
- Update to the latest version (1.3.2). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get document-library-lite --field=version shows what you run; wp plugin update document-library-lite updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-48200 · published 2026-10-29
Information disclosure in Document Library Lite (1.3.0 and older)
- Affected
- 1.3.0 and older
- Fixed in
- 1.3.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in Barn2 Plugins Document Library Lite document-library-lite allows Retrieve Embedded Sensitive Data.This issue affects Document Library Lite: from n/a through 1.3.0.
medium 5.3 CVE-2025-67985 · published 2025-12-16
Missing authorization check in Document Library Lite (1.1.7 and older)
- Affected
- 1.1.7 and older
- Fixed in
- 1.2.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in Barn2 Plugins Document Library Lite document-library-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Document Library Lite: from n/a through <= 1.1.7.
medium 5.9 CVE-2025-67986 · published 2025-12-16
Cross-site scripting (XSS) in Document Library Lite (1.1.7 and older)
- Affected
- 1.1.7 and older
- Fixed in
- 1.2.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Document Library Lite document-library-lite allows DOM-Based XSS.This issue affects Document Library Lite: from n/a through <= 1.1.7.
medium 5.3 CVE-2025-11174 · published 2025-11-01
Missing authorization check in Document Library Lite (1.1.6 and older)
- Affected
- 1.1.6 and older
- Fixed in
- 1.1.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Document Library Lite plugin for WordPress is vulnerable to Improper Authorization in all versions up to, and including, 1.1.6. This is due to the plugin exposing an unauthenticated AJAX action dll_load_posts which returns a JSON table of document data without performing nonce or capability checks. The handler accepts an attacker-controlled args array where the status option explicitly allows draft, pending, future, and any. This makes it possible for unauthenticated attackers to retrieve unpublished document titles and content via the AJAX endpoint.
NVD CVE-2025-11174Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.3.2).
- 2026-10-29 — Information disclosure disclosed (CVE-2026-48200), fixed in 1.3.1.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-67985), fixed in 1.2.0.
- 2025-12-16 — Cross-site scripting (XSS) disclosed (CVE-2025-67986), fixed in 1.2.0.
Get an email when Document Library Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Document Library Lite (document-library-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Barn2 Plugins (2 tracked)
Types found in this plugin: Missing authorization (2) · Sensitive data exposure (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/document-library-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/document-library-lite"><img src="https://laskyr.com/plugins/document-library-lite/badge.svg" alt="Document Library Lite vulnerability status"></a>