Skip to content
Laskyr

Plugins · document-gallery · data as of 2026-11-04

Is Document Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.1.2)

As of 2026-11-04. 8 issues are on record for older versions; version 5.1.2 or newer fixes all of them that state a fix.

Latest version
5.1.2
Last updated
2026-10-28
Active installs
8,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

This plugin generates thumbnails for documents and displays them in a gallery-like format for easy sharing. — by Dan Rossiter

What to do

  1. Update to the latest version (5.1.2). Anything older than 5.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get document-gallery --field=version shows what you run; wp plugin update document-gallery updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-74921 · published 2026-10-19

Cross-site scripting (XSS) in Document Gallery (4.0 to 5.1.1)

Affected
4.0 to 5.1.1
Fixed in
5.1.2 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Document Gallery WordPress plugin through 5.1.1 does not sanitise or escape several gallery shortcode attributes before embedding them in a single-quoted HTML attribute in the rendered gallery markup, allowing users with the Contributor role and above to inject arbitrary event handlers that execute when a higher privileged user views the content.

NVD CVE-2026-74921WPScan advisory

medium 5.3 CVE-2026-74922 · published 2026-10-19

Security issue in Document Gallery (4.1 to 5.1.1)

Affected
4.1 to 5.1.1
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Document Gallery WordPress plugin through 5.1.1 does not verify the signature on one of its unauthenticated webhook endpoints when no shared secret has been configured, which is the default state, allowing unauthenticated users to replace the thumbnail image the site publishes for any document.

NVD CVE-2026-74922WPScan advisory

medium 5.3 CVE-2026-74923 · published 2026-10-16

Information disclosure in Document Gallery (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Document Gallery WordPress plugin through 5.1.1 does not perform any capability or ownership check when generating a gallery on demand, allowing unauthenticated users to enumerate and disclose the titles, descriptions and direct file URLs of media attached to unpublished, private or trashed content.

NVD CVE-2026-74923WPScan advisory

high 7.1 CVE-2026-74920 · published 2026-10-15

Reflected cross-site scripting (XSS) in Document Gallery (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Document Gallery WordPress plugin through 5.1.1 does not properly sanitise and escape user input before reflecting it inside an HTML attribute in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against any visitor, including a logged-in administrator.

NVD CVE-2026-74920WPScan advisory

high 7.2 CVE-2026-77114 · published 2026-10-14

Stored cross-site scripting (XSS) in Document Gallery (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Document Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'dg_thumber_webhook' Action Request Body in all versions up to, and including, 5.1.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that logging be enabled in the plugin's Advanced settings, which is only the default state when WP_DEBUG is true; otherwise an administrator must manually enable it.

NVD CVE-2026-77114Wordfence advisoryPlugin source

high 7.1 CVE-2026-39781 · published 2026-10-06

Reflected cross-site scripting (XSS) in Document Gallery (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dan Rossiter Document Gallery document-gallery allows Reflected XSS.This issue affects Document Gallery: from n/a through 5.1.1.

NVD CVE-2026-39781Patchstack advisory

medium 6.1 CVE-2026-12982 · published 2026-07-27

Reflected cross-site scripting (XSS) in Document Gallery (older than 5.1.1)

Affected
older than 5.1.1
Fixed in
5.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Document Gallery WordPress plugin before 5.1.1 does not properly sanitise and escape user input before reflecting it back in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against unauthenticated users.

NVD CVE-2026-12982WPScan advisory

high 7.1 CVE-2026-57695 · published 2026-07-13

Reflected cross-site scripting (XSS) in Document Gallery (5.1.0 and older)

Affected
5.1.0 and older
Fixed in
5.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dan Rossiter Document Gallery document-gallery allows Reflected XSS.This issue affects Document Gallery: from n/a through <= 5.1.0.

NVD CVE-2026-57695Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Document Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/document-gallery"><img src="https://laskyr.com/plugins/document-gallery/badge.svg" alt="Document Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit