Skip to content
Laskyr

Plugins · document-emberdder · data as of 2026-11-04

Is Document Embedder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.0)

As of 2026-11-04. 6 issues are on record for older versions; version 2.4.1 or newer fixes all of them that state a fix.

Latest version
2.5.0
Last updated
2026-10-18
Active installs
9,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Embed PDF, Word, Excel & PowerPoint in WordPress. PDF viewer, 3D flipbook and document library with Gutenberg block & Elementor widget. — by bPlugins

What to do

  1. Update to the latest version (2.5.0). Anything older than 2.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get document-emberdder --field=version shows what you run; wp plugin update document-emberdder updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-109370 · published 2026-10-28

DOM-based cross-site scripting (XSS) in Document Embedder (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Document Embedder – let visitors read files without downloading plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'content (post_content containing block JSON documentSource.doc)' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is triggered specifically when the victim clicks the embedded document's Download button, which causes the de_track_download AJAX fallback path to programmatically create an anchor with the attacker-controlled href and call .click() — a condition reached because supplying docId=0 causes can_read_document() to return false, bypassing the normal download flow.

NVD CVE-2026-109370Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-62037 · published 2026-10-10

Cross-site scripting (XSS) in Document Embedder (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Document Embedder <= 2.4.0 versions.

NVD CVE-2026-62037Patchstack advisory

medium 5.3 CVE-2026-16567 · published 2026-08-27

Missing authorization check in Document Embedder (older than 2.3.1)

Affected
older than 2.3.1
Fixed in
2.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Document Embedder WordPress plugin before 2.3.1 does not check a document's status before issuing a download token and streaming the file, allowing unauthenticated attackers to download arbitrary Document Embedder WordPress plugin before 2.3.1 documents, including private and draft ones, by enumerating IDs.

NVD CVE-2026-16567WPScan advisory

medium 4.3 CVE-2026-1389 · published 2026-01-28

Missing authorization check in Document Embedder (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Document Embedder – Embed PDFs, Word, Excel, and Other Files plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.0.4. This is due to the plugin not verifying that a user has permission to access the requested resource in the 'bplde_save_document_library', 'bplde_get_single', and 'bplde_delete_document_library' AJAX actions. This makes it possible for authenticated attackers, with Author-level access and above, to read, modify, and delete Document Library entries created by other users, including administrators, via the 'id' parameter.

NVD CVE-2026-1389Wordfence advisoryPlugin source

medium 5.3 CVE-2021-24775 · published 2022-02-01

Security issue in Document Embedder (older than 1.7.5)

Affected
older than 1.7.5
Fixed in
1.7.5
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The Document Embedder WordPress plugin before 1.7.5 contains a REST endpoint, which could allow unauthenticated users to enumerate the title of arbitrary private and draft posts.

NVD CVE-2021-24775WPScan advisory

medium 4.3 CVE-2021-24868 · published 2022-02-01

Security issue in Document Embedder (older than 1.7.9)

Affected
older than 1.7.9
Fixed in
1.7.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by NVD
Details from the advisory

The Document Embedder WordPress plugin before 1.7.9 contains a AJAX action endpoint, which could allow any authenticated user, such as subscriber to enumerate the title of arbitrary private and draft posts.

NVD CVE-2021-24868WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Document Embedder vulnerability status badge
<a href="https://laskyr.com/plugins/document-emberdder"><img src="https://laskyr.com/plugins/document-emberdder/badge.svg" alt="Document Embedder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit