Skip to content
Laskyr

Plugins · dk-pricr-responsive-pricing-table · data as of 2026-11-04

Is Responsive Pricing Table safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.1.13)

As of 2026-11-04. 5 issues are on record for older versions; version 5.1.13 or newer fixes all of them that state a fix.

Latest version
5.1.13
Last updated
2026-01-29
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
6.9.11

A responsive and elegant way to present your offer to your visitors. Create a new pricing table now and copy-paste the shortcode anywhere. — by WP Darko

What to do

  1. Update to the latest version (5.1.13). Anything older than 5.1.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dk-pricr-responsive-pricing-table --field=version shows what you run; wp plugin update dk-pricr-responsive-pricing-table updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-15058 · published 2026-01-07

Stored cross-site scripting (XSS) in Responsive Pricing Table (5.1.12 and older)

Affected
5.1.12 and older
Fixed in
5.1.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Pricing Table plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'table_currency' parameter in all versions up to, and including, 5.1.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-15058Wordfence advisoryCode change (fix)wordpress.org

medium 6.4 CVE-2025-13418 · published 2026-01-07

Stored cross-site scripting (XSS) in Responsive Pricing Table (5.1.12 and older)

Affected
5.1.12 and older
Fixed in
5.1.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Pricing Table plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'plan_icons' parameter in all versions up to, and including, 5.1.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13418Wordfence advisoryCode change (fix)wordpress.org

medium 5.4 CVE-2024-1333 · published 2024-03-18

Stored cross-site scripting (XSS) in Responsive Pricing Table (older than 5.1.11)

Affected
older than 5.1.11
Fixed in
5.1.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Responsive Pricing Table WordPress plugin before 5.1.11 does not validate and escape some of its Pricing Table options before outputting them back in a page/post where the related shortcode is embed, which could allow users with the author role and above to perform Stored Cross-Site Scripting attacks

NVD CVE-2024-1333WPScan advisory

medium 4.8 CVE-2023-4810 · published 2023-11-06

Stored cross-site scripting (XSS) in Responsive Pricing Table (older than 5.1.8)

Affected
older than 5.1.8
Fixed in
5.1.8
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Responsive Pricing Table WordPress plugin before 5.1.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2023-4810WPScan advisoryportswigger.net

medium 5.4 CVE-2022-46855 · published 2023-03-28

Stored cross-site scripting (XSS) in Responsive Pricing Table (5.1.6 and older)

Affected
5.1.6 and older
Fixed in
5.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in WP Darko Responsive Pricing Table plugin <= 5.1.6 versions.

NVD CVE-2022-46855Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Responsive Pricing Table vulnerability status badge
<a href="https://laskyr.com/plugins/dk-pricr-responsive-pricing-table"><img src="https://laskyr.com/plugins/dk-pricr-responsive-pricing-table/badge.svg" alt="Responsive Pricing Table vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit