Skip to content
Laskyr

Plugins · dk-pdf · data as of 2026-11-04

Is DK PDF safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.1 or newer fixes all of them that state a fix.

Latest version
2.3.1
Last updated
2026-09-21
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.0+

DK PDF allows your site visitors generate PDF files from WordPress posts, pages, custom post types and WooCommerce products using a button. — by Torsten Chmielewski Bulk

What to do

  1. Update to the latest version (2.3.1). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dk-pdf --field=version shows what you run; wp plugin update dk-pdf updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.0 CVE-2025-14793 · published 2026-01-16

Server-side request forgery (SSRF) in DK PDF (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The DK PDF – WordPress PDF Generator plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.3.0 via the 'addContentToMpdf' function. This makes it possible for authenticated attackers, author level and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-14793Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-8727 · published 2024-10-01

Reflected cross-site scripting (XSS) in DK PDF (1.9.6 and older)

Affected
1.9.6 and older
Fixed in
1.9.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The DK PDF plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.9.6. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8727Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DK PDF vulnerability status badge
<a href="https://laskyr.com/plugins/dk-pdf"><img src="https://laskyr.com/plugins/dk-pdf/badge.svg" alt="DK PDF vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit