Plugins · display-a-meta-field-as-block · data as of 2026-11-04
Is Meta Field Block safe? Known vulnerabilities and latest version
- Latest version
- 1.6.2
- Last updated
- 2026-10-20
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
A single block to display custom fields in the Block Editor. It supports ACF, MetaBox, WooCommerce, meta, rest field, shortcode and more. — by Phi Phan
What to do
- Update to the latest version (1.6.2). Anything older than 1.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get display-a-meta-field-as-block --field=version shows what you run; wp plugin update display-a-meta-field-as-block updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-3173 · published 2026-05-28
Missing authorization check in Meta Field Block (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Meta Field Block plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.5.1. This is due to the plugin allowing users to specify arbitrary object IDs and object types via block attributes without validating whether the authenticated user has permission to access the requested object's metadata. This makes it possible for authenticated attackers, with Contributor-level access and above, to read arbitrary user meta, post meta, and term meta data from any object in the database. On sites using plugins that store sensitive data in meta fields (e.g., WooCommerce billing/shipping information), this could lead to the exposure of Personally Identifiable Information (PII) including names, email addresses, phone numbers, and physical addresses.
NVD CVE-2026-3173Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-6252 · published 2026-05-14
Stored cross-site scripting (XSS) in Meta Field Block (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Meta Field Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'tagName' block attribute in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.5 CVE-2024-43278 · published 2024-08-18
Stored cross-site scripting (XSS) in Meta Field Block (1.2.13 and older)
- Affected
- 1.2.13 and older
- Fixed in
- 1.2.14
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Phi Phan Meta Field Block allows Stored XSS.This issue affects Meta Field Block: from n/a through 1.2.13.
Recent activity
- 2026-10-20 — latest release on wordpress.org (1.6.2).
- 2026-05-28 — Missing authorization check disclosed (CVE-2026-3173), fixed in 1.5.2.
- 2026-05-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-6252), fixed in 1.5.3.
- 2024-08-18 — Stored cross-site scripting (XSS) disclosed (CVE-2024-43278), fixed in 1.2.14.
Get an email when Meta Field Block has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Meta Field Block (display-a-meta-field-as-block) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/display-a-meta-field-as-block (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/display-a-meta-field-as-block"><img src="https://laskyr.com/plugins/display-a-meta-field-as-block/badge.svg" alt="Meta Field Block vulnerability status"></a>