Skip to content
Laskyr

Plugins · direct-payments-wp · data as of 2026-11-04

Is Direct Payments WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.3 or newer fixes all of them that state a fix.

Latest version
1.4.1
Last updated
2026-07-27
Active installs
50+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Direct Payments WP lets you easily accept payments via bank transfers, mobile money, and P2P platforms on your WordPress website. — by Digages

What to do

  1. Update to the latest version (1.4.1). Anything older than 1.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get direct-payments-wp --field=version shows what you run; wp plugin update direct-payments-wp updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-49340 · published 2025-12-31

Information disclosure in Direct Payments WP (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Digages Direct Payments WP direct-payments-wp allows Retrieve Embedded Sensitive Data.This issue affects Direct Payments WP: from n/a through <= 1.3.2.

NVD CVE-2025-49340Patchstack advisory

medium 4.3 CVE-2025-49339 · published 2025-12-31

Missing authorization check in Direct Payments WP (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Digages Direct Payments WP direct-payments-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Direct Payments WP: from n/a through <= 1.3.2.

NVD CVE-2025-49339Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Direct Payments WP vulnerability status badge
<a href="https://laskyr.com/plugins/direct-payments-wp"><img src="https://laskyr.com/plugins/direct-payments-wp/badge.svg" alt="Direct Payments WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit