Skip to content
Laskyr

Plugins · devvn-image-hotspot · data as of 2026-11-04

Is Image Hotspot by DevVN safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.0 or newer fixes all of them that state a fix.

Latest version
1.3.0
Last updated
2025-12-11
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Image Hotspot by DevVN helps you add hotspots to your images. — by Le Van Toan

What to do

  1. Update to the latest version (1.3.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get devvn-image-hotspot --field=version shows what you run; wp plugin update devvn-image-hotspot updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14445 · published 2026-02-19

Stored cross-site scripting (XSS) in Image Hotspot by DevVN (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Image Hotspot by DevVN plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'hotspot_content' custom field meta in all versions up to, and including, 1.2.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14445Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-7656 · published 2024-08-24

PHP object injection in Image Hotspot by DevVN (1.2.5 and older)

Affected
1.2.5 and older
Fixed in
1.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Image Hotspot by DevVN plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.2.5 via deserialization of untrusted input in the 'devvn_ihotspot_shortcode_func' function. This makes it possible for authenticated attackers, with Author-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2024-7656Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Image Hotspot by DevVN vulnerability status badge
<a href="https://laskyr.com/plugins/devvn-image-hotspot"><img src="https://laskyr.com/plugins/devvn-image-hotspot/badge.svg" alt="Image Hotspot by DevVN vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit