Skip to content
Laskyr

Plugins · devs-accounting · data as of 2026-11-04

Is Devs Accounting safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.4)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.1 or newer fixes all of them that state a fix.

Latest version
1.2.4
Last updated
2026-07-02
Active installs
fewer than 10
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4.25+

Easily create your simple eCommerce store, get orders and also manage accounting and get automated reports. — by Devsbrain

What to do

  1. Update to the latest version (1.2.4). Anything older than 1.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get devs-accounting --field=version shows what you run; wp plugin update devs-accounting updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-9175 · published 2026-06-24

Missing authorization check in Devs Accounting (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Devs Accounting – Simple Accounting and Invoicing Solution plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.2.0. This is due to the get_single_account() REST API callback being registered with a permission_callback that unconditionally returns true, providing no authentication or authorization checks on the /devs-accounting/v1/get-account/<id> endpoint. This makes it possible for unauthenticated attackers to read arbitrary private financial account records (including account name, bank name, and opening balance) by enumerating the numeric account ID, resulting in sensitive information disclosure.

NVD CVE-2026-9175Wordfence advisoryPlugin source

medium 5.3 CVE-2026-9172 · published 2026-06-24

Missing authorization check in Devs Accounting (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Devs Accounting – Simple Accounting and Invoicing Solution plugin for WordPress is vulnerable to unauthorized modification/deletion of data due to a missing capability check on the delete_single_account() function in versions up to, and including, 1.2.0. The REST route 'devs-accounting/v1/delete-account/(?P<id>\d+)' is registered without any permission_callback, which causes WordPress to expose the endpoint to public, unauthenticated access. This makes it possible for unauthenticated attackers to soft-delete arbitrary accounting account records (wp_dac_accounts) by issuing a simple GET request to the endpoint with any account ID.

NVD CVE-2026-9172Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Devs Accounting vulnerability status badge
<a href="https://laskyr.com/plugins/devs-accounting"><img src="https://laskyr.com/plugins/devs-accounting/badge.svg" alt="Devs Accounting vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit