Skip to content
Laskyr

Plugins · demo-importer-plus · data as of 2026-11-04

Is Demo Importer Plus safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.12)

As of 2026-11-04. 5 issues are on record for older versions; version 2.0.10 or newer fixes all of them that state a fix.

Latest version
2.0.12
Last updated
2026-08-27
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.4+

Import the demo content, widgets, customizer settings and theme settings with a single click without any hassle. — by Kraft Plugins

What to do

  1. Update to the latest version (2.0.12). Anything older than 2.0.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get demo-importer-plus --field=version shows what you run; wp plugin update demo-importer-plus updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-14478 · published 2026-01-17

Security issue in Demo Importer Plus (2.0.9 and older)

Affected
2.0.9 and older
Fixed in
2.0.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Demo Importer Plus plugin for WordPress is vulnerable to XML External Entity Injection (XXE) in all versions up to, and including, 2.0.9 via the SVG file upload functionality. This makes it possible for authenticated attackers, with Author-level access and above, to achieve code execution in vulnerable configurations. This only impacts sites on versions of PHP older than 8.0.

NVD CVE-2025-14478Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-69091 · published 2025-12-30

Missing authorization check in Demo Importer Plus (2.0.8 and older)

Affected
2.0.8 and older
Fixed in
2.0.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Kraft Plugins Demo Importer Plus demo-importer-plus allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Demo Importer Plus: from n/a through <= 2.0.8.

NVD CVE-2025-69091Patchstack advisory

high 8.8 CVE-2025-14364 · published 2025-12-18

Privilege escalation in Demo Importer Plus (2.0.8 and older)

Affected
2.0.8 and older
Fixed in
2.0.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Demo Importer Plus plugin for WordPress is vulnerable to unauthorized modification of data, loss of data, and privilege escalation due to a missing capability check on the Ajax::handle_request() function in all versions up to, and including, 2.0.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to trigger a full site reset, dropping all database tables except users/usermeta and re-running wp_install(), which also assigns the Administrator role to the attacking subscriber account.

NVD CVE-2025-14364Wordfence advisoryCode change (fix)

high 8.8 CVE-2025-13066 · published 2025-12-05

Arbitrary file upload in Demo Importer Plus (2.0.6 and older)

Affected
2.0.6 and older
Fixed in
2.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Demo Importer Plus plugin for WordPress is vulnerable to arbitrary file upload in all versions up to, and including, 2.0.6. This is due to insufficient file type validation detecting WXR files, allowing double extension files to bypass sanitization while being accepted as a valid WXR file. This makes it possible for authenticated attackers, with author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-13066Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-9172 · published 2024-10-02

Stored cross-site scripting (XSS) in Demo Importer Plus (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Demo Importer Plus plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 2.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.

NVD CVE-2024-9172Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Demo Importer Plus vulnerability status badge
<a href="https://laskyr.com/plugins/demo-importer-plus"><img src="https://laskyr.com/plugins/demo-importer-plus/badge.svg" alt="Demo Importer Plus vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit