Plugins · demi-backup-migration · data as of 2026-11-04
Is Demi safe? Known vulnerabilities and latest version
- Latest version
- 0.1.3
- Last updated
- 2026-09-11
- Active installs
- 300+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Demi is an all-in-one WordPress toolkit for demo imports, backups, restores, migrations, search & replace, and site resets. — by deveasel
What to do
- Update to the latest version (0.1.3). Anything older than 0.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get demi-backup-migration --field=version shows what you run; wp plugin update demi-backup-migration updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-15012 · published 2026-07-28
Information disclosure in Demi (0.0.8 and older)
- Affected
- 0.0.8 and older
- Fixed in
- 0.0.9 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Demi – One Click Demo Import, WP Backup & Site Migration plugin for WordPress is vulnerable to Arbitrary Directory Copy in all versions up to, and including, 0.0.8 via the handle_restore_step function. This is due to missing HTTP access controls on the wp-content/uploads/demi-backup-state/ directory, which exposes the cryptographic restore key used to both authenticate the unauthenticated AJAX handler and forge signed restore-state envelopes. This makes it possible for unauthenticated attackers to copy arbitrary files to attacker-controlled destinations on the server. An active restore operation must have been initiated, which writes the .restore_key and .restore_step_token files to the public upload directory, before the exposed secrets can be harvested and chained to achieve unauthenticated arbitrary file copy.
NVD CVE-2026-15012Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-14490 · published 2026-07-28
Path traversal / file read in Demi (0.0.7 and older)
- Affected
- 0.0.7 and older
- Fixed in
- 0.0.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Demi – One Click Demo Import, WP Backup & Site Migration plugin for WordPress is vulnerable to Arbitrary Directory Deletion in all versions up to, and including, 0.0.7. The vulnerability exists because the plugin stores its HMAC signing key and per-step restore token as dotfiles inside a publicly accessible subdirectory of the WordPress uploads folder — without any `.htaccess` or index file protection — and the `demi_restore_step` AJAX handler, registered for unauthenticated callers, explicitly accepts possession of the on-disk signing key as a standalone alternative to WordPress capability and nonce checks; an unauthenticated attacker who retrieves the exposed key can forge a valid signed state envelope to invoke `CleanDir::execute()` with a caller-supplied absolute path that is subject to no allow-list or path-canonicalization check. This makes it possible for unauthenticated attackers to recursively delete arbitrary directories on the server.
NVD CVE-2026-14490Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-11 — latest release on wordpress.org (0.1.3).
- 2026-07-28 — Information disclosure disclosed (CVE-2026-15012), fixed in 0.0.9.
- 2026-07-28 — Path traversal / file read disclosed (CVE-2026-14490), fixed in 0.0.8.
Get an email when Demi has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Demi (demi-backup-migration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/demi-backup-migration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/demi-backup-migration"><img src="https://laskyr.com/plugins/demi-backup-migration/badge.svg" alt="Demi vulnerability status"></a>