Skip to content
Laskyr

Plugins · decorator-woocommerce-email-customizer · data as of 2026-11-04

Is WebToffee eCommerce Marketing Automation safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.2 or newer fixes all of them that state a fix.

Latest version
2.1.8
Last updated
2026-08-18
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Create and send marketing emails and campaigns. Enable email automations, Popups, spin-a-wheel, sign-up forms, and more. Customize WooCommerce emails. — by WebToffee

What to do

  1. Update to the latest version (2.1.8). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get decorator-woocommerce-email-customizer --field=version shows what you run; wp plugin update decorator-woocommerce-email-customizer updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-67599 · published 2025-12-09

Missing authorization check in WebToffee eCommerce Marketing Automation (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.1.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebToffee WebToffee eCommerce Marketing Automation decorator-woocommerce-email-customizer allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WebToffee eCommerce Marketing Automation: from n/a through <= 2.1.1.

NVD CVE-2025-67599Patchstack advisory

high 8.8 CVE-2023-48284 · published 2023-11-30

Cross-site request forgery (CSRF) in WebToffee eCommerce Marketing Automation (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WebToffee Decorator – WooCommerce Email Customizer allows Cross Site Request Forgery.This issue affects Decorator – WooCommerce Email Customizer: from n/a through 1.2.7.

NVD CVE-2023-48284Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WebToffee eCommerce Marketing Automation vulnerability status badge
<a href="https://laskyr.com/plugins/decorator-woocommerce-email-customizer"><img src="https://laskyr.com/plugins/decorator-woocommerce-email-customizer/badge.svg" alt="WebToffee eCommerce Marketing Automation vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit