Skip to content
Laskyr

Plugins · debugger-troubleshooter · data as of 2026-11-04

Is Debugger & Troubleshooter safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.4.0 or newer fixes all of them that state a fix.

Latest version
1.5.1
Last updated
2026-10-20
Active installs
90+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A WordPress plugin for debugging & troubleshooting. Safely simulate plugin deactivation, theme switching, and WP_DEBUG. — by Jhimross Olinares

What to do

  1. Update to the latest version (1.5.1). Anything older than 1.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get debugger-troubleshooter --field=version shows what you run; wp plugin update debugger-troubleshooter updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-5130 · published 2026-03-30

Privilege escalation in Debugger & Troubleshooter (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Debugger & Troubleshooter plugin for WordPress was vulnerable to Unauthenticated Privilege Escalation in versions up to and including 1.3.2. This was due to the plugin accepting the wp_debug_troubleshoot_simulate_user cookie value directly as a user ID without any cryptographic validation or authorization checks. The cookie value was used to override the determine_current_user filter, which allowed unauthenticated attackers to impersonate any user by simply setting the cookie to their target user ID. This made it possible for unauthenticated attackers to gain administrator-level access and perform any privileged actions including creating new administrator accounts, modifying site content, installing plugins, or taking complete control of the WordPress site. The vulnerability was fixed in version 1.4.0 by implementing a cryptographic token-based validation system where only administrators can initiate user simulation, and the cookie contains a random 64-character token that must be validated against database-stored mappings rather than accepting arbitrary user IDs.

NVD CVE-2026-5130Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Debugger & Troubleshooter vulnerability status badge
<a href="https://laskyr.com/plugins/debugger-troubleshooter"><img src="https://laskyr.com/plugins/debugger-troubleshooter/badge.svg" alt="Debugger & Troubleshooter vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit