Skip to content
Laskyr

Plugins · debloat · data as of 2026-11-04

Is Debloat safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.4.0 or newer fixes all of them that state a fix.

Latest version
1.4.0
Last updated
2026-10-09
Active installs
30,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.1+

Remove Unused CSS, Optimize CSS, Optimize JS and speed up your site. — by asadkn

What to do

  1. Update to the latest version (1.4.0). Anything older than 1.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get debloat --field=version shows what you run; wp plugin update debloat updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-104769 · published 2026-10-16

Path traversal / file read in Debloat (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Debloat – Remove Unused CSS, Optimize JS plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.3.0 via the 's' parameter parameter. This makes it possible for authenticated attackers, with administrator-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information. Exploitation requires that the site administrator has enabled the Optimize CSS feature (with the default Inline Google Fonts option active), but once that condition is met the attack is trivially triggered by an unauthenticated visitor with a single crafted GET request to the public search URL.

NVD CVE-2026-104769Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Debloat vulnerability status badge
<a href="https://laskyr.com/plugins/debloat"><img src="https://laskyr.com/plugins/debloat/badge.svg" alt="Debloat vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit