Skip to content
Laskyr

Plugins · dealia-request-a-quote · data as of 2026-11-04

Is Dealia safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.9 or newer fixes all of them that state a fix.

Latest version
1.0.9
Last updated
2026-04-15
Active installs
fewer than 10
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Dealia is a quote management platform that allows to receive quote requests directly from your website, negotiate prices and make stress-free deals. — by dealia

What to do

  1. Update to the latest version (1.0.9). Anything older than 1.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dealia-request-a-quote --field=version shows what you run; wp plugin update dealia-request-a-quote updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-2718 · published 2026-02-19

Stored cross-site scripting (XSS) in Dealia (1.0.8 and older)

Affected
1.0.8 and older
Fixed in
1.0.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Dealia – Request a Quote plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Gutenberg block attributes in all versions up to, and including, 1.0.8. This is due to the use of `wp_kses()` for output escaping within HTML attribute contexts where `esc_attr()` is required. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2718Wordfence advisoryPlugin source

medium 4.3 CVE-2026-2504 · published 2026-02-19

Missing authorization check in Dealia (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
1.0.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Dealia – Request a quote plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on multiple AJAX handlers in all versions up to, and including, 1.0.7. The admin nonce (DEALIA_ADMIN_NONCE) is exposed to all users with edit_posts capability (Contributor+) via wp_localize_script() in PostsController.php, while the AJAX handlers in AdminSettingsController.php only verify the nonce without checking current_user_can('manage_options'). This makes it possible for authenticated attackers, with Contributor-level access and above, to reset the plugin configuration.

NVD CVE-2026-2504Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Dealia vulnerability status badge
<a href="https://laskyr.com/plugins/dealia-request-a-quote"><img src="https://laskyr.com/plugins/dealia-request-a-quote/badge.svg" alt="Dealia vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit