Plugins · datalogics · data as of 2026-11-04
Is Datalogics Ecommerce Delivery safe? Known vulnerabilities and latest version
- Latest version
- 2.6.66
- Last updated
- 2026-05-28
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.4+
Datalogics Ecommerce Delivery enables seamless syncing of your WooCommerce orders with a variety of delivery companies, automating the entire shipping … — by Datalogics
What to do
- Update to the latest version (2.6.66). Anything older than 2.6.66 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get datalogics --field=version shows what you run; wp plugin update datalogics updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-9613 · published 2026-09-19
Missing authorization check in Datalogics Ecommerce Delivery (2.6.65 and older)
- Affected
- 2.6.65 and older
- Fixed in
- 2.6.66 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Datalogics Ecommerce Delivery – Datalogics plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.6.65. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to create and cancel real shipping orders through the external logistics API using the store's stored authentication token, modify arbitrary WooCommerce order post meta on any order, overwrite the plugin's stored API token, and trigger shipping notification emails to customers.
NVD CVE-2026-9613Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2026-39583 · published 2026-06-15
Privilege escalation in Datalogics Ecommerce Delivery (2.6.62 and older)
- Affected
- 2.6.62 and older
- Fixed in
- 2.6.63
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Privilege Escalation in Datalogics Ecommerce Delivery <= 2.6.62 versions.
critical 9.8 CVE-2026-2631 · published 2026-03-11
Privilege escalation in Datalogics Ecommerce Delivery (older than 2.6.60)
- Affected
- older than 2.6.60
- Fixed in
- 2.6.60
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Datalogics Ecommerce Delivery WordPress plugin before 2.6.60 exposes an unauthenticated REST endpoint that allows any remote user to modify the option `datalogics_token` without verification. This token is subsequently used for authentication in a protected endpoint that allows users to perform arbitrary WordPress `update_option()` operations. Attackers can use this to enable registartion and to set the default role as Administrator.
Recent activity
- 2026-05-28 — latest release on wordpress.org (2.6.66).
- 2026-09-19 — Missing authorization check disclosed (CVE-2026-9613), fixed in 2.6.66.
- 2026-06-15 — Privilege escalation disclosed (CVE-2026-39583), fixed in 2.6.63.
- 2026-03-11 — Privilege escalation disclosed (CVE-2026-2631), fixed in 2.6.60.
Get an email when Datalogics Ecommerce Delivery has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Datalogics Ecommerce Delivery (datalogics) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/datalogics (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/datalogics"><img src="https://laskyr.com/plugins/datalogics/badge.svg" alt="Datalogics Ecommerce Delivery vulnerability status"></a>