Plugins · database-for-cf7 · data as of 2026-11-04
Is Database for CF7 safe? Known vulnerabilities and latest version
- Status
- Closed 2026-07-16
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate database-for-cf7 && wp plugin delete database-for-cf7
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
high 7.1 CVE-2026-39731 · published 2026-10-06
Cross-site scripting (XSS) in Database for CF7 (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Database for CF7 <= 1.2.6 versions.
high 7.2 CVE-2026-13425 · published 2026-07-29
Stored cross-site scripting (XSS) in Database for CF7 (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Database for CF7 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Array Form Field Values in all versions up to, and including, 1.2.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by unauthenticated attackers because Contact Form 7 accepts array-structured input for ordinary text fields (e.g., your-name[]) via the public REST API endpoint /wp-json/contact-form-7/v1/contact-forms/{id}/feedback, and the plugin stores submitted data using $wpdb INSERT with serialize() into a custom wp_cf7db table, bypassing WordPress save-time filtering via wp_insert_post/wp_kses.
medium 6.5 CVE-2023-49167 · published 2024-12-09
Missing authorization check in Database for CF7 (1.2.4 and older)
- Affected
- 1.2.4 and older
- Fixed in
- 1.2.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in code4life Database for CF7 database-for-cf7 allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Database for CF7: from n/a through <= 1.2.4.
Recent activity
- 2026-07-16 — closed on wordpress.org (Security Issue).
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-39731), fix version not stated.
- 2026-07-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-13425), fix version not stated.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-49167), fixed in 1.2.5.
Get an email when Database for CF7 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Database for CF7 (database-for-cf7) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/database-for-cf7 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/database-for-cf7"><img src="https://laskyr.com/plugins/database-for-cf7/badge.svg" alt="Database for CF7 vulnerability status"></a>