Skip to content
Laskyr

Plugins · database-cleaner · data as of 2026-11-04

Is Database Cleaner safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.8)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4.8 or newer fixes all of them that state a fix.

Latest version
1.4.8
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Clean up and optimize your WordPress database: revisions, transients, autoload, orphaned data. Built for large databases, safe and fast. — by Jordy Meow

What to do

  1. Update to the latest version (1.4.8). Anything older than 1.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get database-cleaner --field=version shows what you run; wp plugin update database-cleaner updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.7 CVE-2025-8574 · published 2026-10-30

Missing authorization check in Database Cleaner (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Database Cleaner plugin for WordPress is vulnerable to arbitrary table deletion in all versions up to, and including, 1.4.7. This is due to a lack of restriction on database tables that can be deleted. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete core WordPress tables.

NVD CVE-2025-8574Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2024-35712 · published 2024-06-10

Path traversal / file read in Database Cleaner (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Jordy Meow Database Cleaner allows Relative Path Traversal.This issue affects Database Cleaner: from n/a through 1.0.5.

NVD CVE-2024-35712Patchstack advisory

high 7.5 CVE-2023-51508 · published 2024-01-08

Information disclosure in Database Cleaner (0.9.8 and older)

Affected
0.9.8 and older
Fixed in
0.9.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Jordy Meow Database Cleaner: Clean, Optimize & Repair.This issue affects Database Cleaner: Clean, Optimize & Repair: from n/a through 0.9.8.

NVD CVE-2023-51508Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Database Cleaner vulnerability status badge
<a href="https://laskyr.com/plugins/database-cleaner"><img src="https://laskyr.com/plugins/database-cleaner/badge.svg" alt="Database Cleaner vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit