Skip to content
Laskyr

Plugins · daggerhart-openid-connect-generic · data as of 2026-11-04

Is OpenID Connect Generic Client safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.11.3)

As of 2026-11-04. 2 issues are on record for older versions; version 3.10.1 or newer fixes all of them that state a fix.

Latest version
3.11.3
Last updated
2026-02-13
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.0 · PHP 7.4+

A simple client that provides SSO or opt-in authentication against a generic OAuth2 Server implementation. — by Jonathan Daggerhart

What to do

  1. Update to the latest version (3.11.3). Anything older than 3.10.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get daggerhart-openid-connect-generic --field=version shows what you run; wp plugin update daggerhart-openid-connect-generic updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-13730 · published 2025-12-18

Stored cross-site scripting (XSS) in OpenID Connect Generic Client (3.10.0 and older)

Affected
3.10.0 and older
Fixed in
3.10.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OpenID Connect Generic Client plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'openid_connect_generic_auth_url' shortcode in all versions up to, and including, 3.10.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13730Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2021-24214 · published 2021-05-06

Reflected cross-site scripting (XSS) in OpenID Connect Generic Client (3.8.0 only, 3.8.1 only)

Affected
3.8.0 only, 3.8.1 only
Fixed in
3.8.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The OpenID Connect Generic Client WordPress plugin 3.8.0 and 3.8.1 did not sanitise the login error when output back in the login form, leading to a reflected Cross-Site Scripting issue. This issue does not require authentication and can be exploited with the default configuration.

NVD CVE-2021-24214WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OpenID Connect Generic Client vulnerability status badge
<a href="https://laskyr.com/plugins/daggerhart-openid-connect-generic"><img src="https://laskyr.com/plugins/daggerhart-openid-connect-generic/badge.svg" alt="OpenID Connect Generic Client vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit