Plugins · cyan-backup · data as of 2026-11-04
Is CYAN Backup safe? Known vulnerabilities and latest version
- Latest version
- 2.5.5
- Last updated
- 2025-11-04
- Active installs
- 300+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12
Backup your entire WordPress site and its database into a zip file on a schedule. Remote storage options include FTP, SFTP and FTPS. — by Greg Ross
What to do
- Update to the latest version (2.5.5). Anything older than 2.5.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cyan-backup --field=version shows what you run; wp plugin update cyan-backup updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-12092 · published 2025-11-08
Arbitrary file deletion in CYAN Backup (2.5.4 and older)
- Affected
- 2.5.4 and older
- Fixed in
- 2.5.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CYAN Backup plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'delete' functionality in all versions up to, and including, 2.5.4. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
NVD CVE-2025-12092Wordfence advisoryCode change (fix)github.com
medium 5.4 CVE-2024-9663 · published 2025-05-15
Stored cross-site scripting (XSS) in CYAN Backup (older than 2.5.3)
- Affected
- older than 2.5.3
- Fixed in
- 2.5.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The CYAN Backup WordPress plugin before 2.5.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 5.4 CVE-2024-9662 · published 2025-05-15
Stored cross-site scripting (XSS) in CYAN Backup (older than 2.5.3)
- Affected
- older than 2.5.3
- Fixed in
- 2.5.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The CYAN Backup WordPress plugin before 2.5.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 4.9 CVE-2024-52390 · published 2024-11-18
Path traversal / file read in CYAN Backup (2.5.3 and older)
- Affected
- 2.5.3 and older
- Fixed in
- 2.5.4
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Path Traversal: '.../...//' vulnerability in Greg Ross CYAN Backup cyan-backup allows Path Traversal.This issue affects CYAN Backup: from n/a through <= 2.5.3.
Recent activity
- 2025-11-04 — latest release on wordpress.org (2.5.5).
- 2025-11-08 — Arbitrary file deletion disclosed (CVE-2025-12092), fixed in 2.5.5.
- 2025-05-15 — Stored cross-site scripting (XSS) disclosed (CVE-2024-9663), fixed in 2.5.3.
- 2025-05-15 — Stored cross-site scripting (XSS) disclosed (CVE-2024-9662), fixed in 2.5.3.
Get an email when CYAN Backup has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CYAN Backup (cyan-backup) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Arbitrary file deletion (1) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cyan-backup (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cyan-backup"><img src="https://laskyr.com/plugins/cyan-backup/badge.svg" alt="CYAN Backup vulnerability status"></a>