Skip to content
Laskyr

Plugins · cww-companion · data as of 2026-11-04

Is CWW Companion safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.3 or newer fixes all of them that state a fix.

Latest version
1.3.9
Last updated
2026-04-13
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

This plugin adds some useful featuers to themes made by us(Code Work Web). — by Code Work Web

What to do

  1. Update to the latest version (1.3.9). Anything older than 1.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cww-companion --field=version shows what you run; wp plugin update cww-companion updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-67473 · published 2025-12-09

Cross-site request forgery (CSRF) in CWW Companion (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in codeworkweb CWW Companion cww-companion allows Cross Site Request Forgery.This issue affects CWW Companion: from n/a through <= 1.3.2.

NVD CVE-2025-67473Patchstack advisory

medium 5.4 CVE-2024-2130 · published 2024-03-12

Stored cross-site scripting (XSS) in CWW Companion (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CWW Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Module2 widget in all versions up to, and including, 1.2.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2130Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CWW Companion vulnerability status badge
<a href="https://laskyr.com/plugins/cww-companion"><img src="https://laskyr.com/plugins/cww-companion/badge.svg" alt="CWW Companion vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit