Plugins · customer-reviews-collector-for-woocommerce · data as of 2026-11-04
Is Customer Reviews Collector for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.7.6
- Last updated
- 2026-05-28
- Active installs
- 5,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Collect reviews on Google, Facebook, Yelp, Trustindex and other platforms automatically, with the help of our system. — by Trustindex
What to do
- Update to the latest version (4.7.6). Anything older than 4.6.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get customer-reviews-collector-for-woocommerce --field=version shows what you run; wp plugin update customer-reviews-collector-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2025-12123 · published 2025-11-27
Reflected cross-site scripting (XSS) in Customer Reviews Collector for WooCommerce (4.6.1 and older)
- Affected
- 4.6.1 and older
- Fixed in
- 4.6.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Customer Reviews Collector for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'email-text' parameter in all versions up to, and including, 4.6.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Recent activity
- 2026-05-28 — latest release on wordpress.org (4.7.6).
- 2025-11-27 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-12123), fixed in 4.6.2.
Get an email when Customer Reviews Collector for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Customer Reviews Collector for WooCommerce (customer-reviews-collector-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Trustindex (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/customer-reviews-collector-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/customer-reviews-collector-for-woocommerce"><img src="https://laskyr.com/plugins/customer-reviews-collector-for-woocommerce/badge.svg" alt="Customer Reviews Collector for WooCommerce vulnerability status"></a>