Skip to content
Laskyr

Plugins · custom-related-posts · data as of 2026-11-04

Is Custom Related Posts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.2)

As of 2026-11-04. 3 issues are on record for older versions; version 1.8.1 or newer fixes all of them that state a fix.

Latest version
1.8.2
Last updated
2026-08-19
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Manual related posts without slowing down your website! — by Brecht

What to do

  1. Update to the latest version (1.8.2). Anything older than 1.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-related-posts --field=version shows what you run; wp plugin update custom-related-posts updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-68033 · published 2026-01-05

Information disclosure in Custom Related Posts (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
1.8.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Brecht Custom Related Posts custom-related-posts allows Retrieve Embedded Sensitive Data.This issue affects Custom Related Posts: from n/a through <= 1.8.0.

NVD CVE-2025-68033Patchstack advisory

medium 5.4 CVE-2025-46227 · published 2025-04-22

Stored cross-site scripting (XSS) in Custom Related Posts (1.7.4 and older)

Affected
1.7.4 and older
Fixed in
1.7.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brecht Custom Related Posts custom-related-posts allows Stored XSS.This issue affects Custom Related Posts: from n/a through <= 1.7.4.

NVD CVE-2025-46227Patchstack advisory

medium 5.4 CVE-2024-12825 · published 2025-02-01

Missing authorization check in Custom Related Posts (1.7.3 and older)

Affected
1.7.3 and older
Fixed in
1.7.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Custom Related Posts plugin for WordPress is vulnerable to unauthorized access & modification of data due to a missing capability check on three AJAX actions in all versions up to, and including, 1.7.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to search posts and link/unlink relations.

NVD CVE-2024-12825Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Related Posts vulnerability status badge
<a href="https://laskyr.com/plugins/custom-related-posts"><img src="https://laskyr.com/plugins/custom-related-posts/badge.svg" alt="Custom Related Posts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit