Plugins · custom-post-widget · data as of 2026-11-04
Is Content Blocks (Custom Post Widget) safe? Known vulnerabilities and latest version
- Latest version
- 3.4.4
- Last updated
- 2026-09-21
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
This plugin enables you to edit and display Content Blocks in a sidebar widget or using a shortcode. — by Johan van der Wijk
What to do
- Update to the latest version (3.4.4). Anything older than 3.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get custom-post-widget --field=version shows what you run; wp plugin update custom-post-widget updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-0894 · published 2026-04-18
Stored cross-site scripting (XSS) in Content Blocks (Custom Post Widget) (3.3.9 and older)
- Affected
- 3.3.9 and older
- Fixed in
- 3.4.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Content Blocks (Custom Post Widget) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's content_block shortcode in all versions up to, and including, 3.3.9 due to insufficient input sanitization and output escaping on user supplied values consumed from user-created content blocks. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2024-6432 · published 2025-02-20
Stored cross-site scripting (XSS) in Content Blocks (Custom Post Widget) (3.3.5 and older)
- Affected
- 3.3.5 and older
- Fixed in
- 3.3.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Content Blocks (Custom Post Widget) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘content’ parameter within the plugin's shortcode Content Block in all versions up to, and including, 3.3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-6432Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 5.4 CVE-2024-44051 · published 2024-09-17
Stored cross-site scripting (XSS) in Content Blocks (Custom Post Widget) (3.3.5 and older)
- Affected
- 3.3.5 and older
- Fixed in
- 3.3.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Johan van der Wijk Content Blocks (Custom Post Widget) custom-post-widget allows Stored XSS.This issue affects Content Blocks (Custom Post Widget): from n/a through <= 3.3.5.
medium 5.4 CVE-2024-3565 · published 2024-06-01
Stored cross-site scripting (XSS) in Content Blocks (Custom Post Widget) (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Content Blocks (Custom Post Widget) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_block' shortcode in all versions up to, and including, 3.3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-3565Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2024-3564 · published 2024-06-01
File inclusion in Content Blocks (Custom Post Widget) (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Content Blocks (Custom Post Widget) plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.3.0 via the plugin's 'content_block' shortcode. This makes it possible for authenticated attackers, with contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
medium 5.4 CVE-2024-34566 · published 2024-05-08
Stored cross-site scripting (XSS) in Content Blocks (Custom Post Widget) (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Johan van der Wijk Content Blocks (Custom Post Widget) allows Stored XSS.This issue affects Content Blocks (Custom Post Widget): from n/a through 3.3.0.
Recent activity
- 2026-09-21 — latest release on wordpress.org (3.4.4).
- 2026-04-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-0894), fixed in 3.4.1.
- 2025-02-20 — Stored cross-site scripting (XSS) disclosed (CVE-2024-6432), fixed in 3.3.6.
- 2024-09-17 — Stored cross-site scripting (XSS) disclosed (CVE-2024-44051), fixed in 3.3.6.
Get an email when Content Blocks (Custom Post Widget) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Content Blocks (Custom Post Widget) (custom-post-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/custom-post-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/custom-post-widget"><img src="https://laskyr.com/plugins/custom-post-widget/badge.svg" alt="Content Blocks (Custom Post Widget) vulnerability status"></a>