Plugins · custom-post-type-ui · data as of 2026-11-01
Is Custom Post Type UI safe? Known vulnerabilities and latest version
- Latest version
- 1.19.3
- Last updated
- 2026-07-14
- Active installs
- 1+ million
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Admin UI for creating custom content types like post types and taxonomies — by webdevstudios
What to do
- Update to the latest version (1.19.3). Anything older than 1.18.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get custom-post-type-ui --field=version shows what you run; wp plugin update custom-post-type-ui updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2025-14056 · published 2025-12-13
Stored cross-site scripting (XSS) in Custom Post Type UI (1.18.1 and older)
- Affected
- 1.18.1 and older
- Fixed in
- 1.18.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Custom Post Type UI plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'label' parameter during custom post type import in all versions up to, and including, 1.18.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses the Tools → Get Code page.
medium 4.8 CVE-2025-12826 · published 2025-12-04
Missing authorization check in Custom Post Type UI (1.18.0 and older)
- Affected
- 1.18.0 and older
- Fixed in
- 1.18.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Custom Post Type UI plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.18.0. This is due to the plugin not verifying that a user has the required capability to perform actions in the "cptui_process_post_type" function. This makes it possible for authenticated attackers, with subscriber level access and above, to add, edit, or delete custom post types in limited situations.
medium 6.5 CVE-2023-1623 · published 2023-04-24
Cross-site request forgery (CSRF) in Custom Post Type UI (older than 1.13.5)
- Affected
- older than 1.13.5
- Fixed in
- 1.13.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Custom Post Type UI WordPress plugin before 1.13.5 does not properly check for CSRF when sending the debug information to a user supplied email, which could allow attackers to make a logged in admin send such information to an arbitrary email address via a CSRF attack.
Recent activity
- 2026-07-14 — latest release on wordpress.org (1.19.3).
- 2025-12-13 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14056), fixed in 1.18.2.
- 2025-12-04 — Missing authorization check disclosed (CVE-2025-12826), fixed in 1.18.1.
- 2023-04-24 — Cross-site request forgery (CSRF) disclosed (CVE-2023-1623), fixed in 1.13.5.
Get an email when Custom Post Type UI has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Custom Post Type UI (custom-post-type-ui) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/custom-post-type-ui (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/custom-post-type-ui"><img src="https://laskyr.com/plugins/custom-post-type-ui/badge.svg" alt="Custom Post Type UI vulnerability status"></a>