Skip to content
Laskyr

Plugins · custom-payment-gateways-woocommerce · data as of 2026-11-04

Is Custom Payment Gateways for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.0)

As of 2026-11-04. 1 issue is on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.2.0
Last updated
2026-09-01
Active installs
8,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Custom payment gateways for WooCommerce - create custom payment gateways to never miss out any payments for your WooCommerce Store. — by Dhruvin

What to do

  1. Update to the latest version (2.2.0). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-payment-gateways-woocommerce --field=version shows what you run; wp plugin update custom-payment-gateways-woocommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-7517 · published 2026-07-01

Stored cross-site scripting (XSS) in Custom Payment Gateways for WooCommerce (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Custom Payment Gateways for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'alg_wc_cpg_input_fields' parameter in all versions up to, and including, 2.1.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable by unauthenticated guest users submitting a crafted checkout POST request, requiring no custom input fields to be configured in the plugin.

NVD CVE-2026-7517Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Payment Gateways for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/custom-payment-gateways-woocommerce"><img src="https://laskyr.com/plugins/custom-payment-gateways-woocommerce/badge.svg" alt="Custom Payment Gateways for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit