Skip to content
Laskyr

Plugins · custom-order-numbers-for-woocommerce · data as of 2026-11-04

Is Custom Order Numbers for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.11.1 or newer fixes all of them that state a fix.

Latest version
2.2.0
Last updated
2026-09-28
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Set Sequential order numbers in WooCommerce. Custom order number with prefixes can also be set for existing and new WooCommerce orders. — by tychesoftwares

What to do

  1. Update to the latest version (2.2.0). Anything older than 1.11.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-order-numbers-for-woocommerce --field=version shows what you run; wp plugin update custom-order-numbers-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-66071 · published 2025-11-21

Missing authorization check in Custom Order Numbers for WooCommerce (1.11.0 and older)

Affected
1.11.0 and older
Fixed in
1.11.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in tychesoftwares Custom Order Numbers for WooCommerce custom-order-numbers-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Custom Order Numbers for WooCommerce: from n/a through <= 1.11.0.

NVD CVE-2025-66071Patchstack advisory

high 8.8 CVE-2022-45367 · published 2023-05-25

Cross-site request forgery (CSRF) in Custom Order Numbers for WooCommerce (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Tyche Softwares Custom Order Numbers for WooCommerce plugin <= 1.4.0 versions.

NVD CVE-2022-45367Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Order Numbers for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/custom-order-numbers-for-woocommerce"><img src="https://laskyr.com/plugins/custom-order-numbers-for-woocommerce/badge.svg" alt="Custom Order Numbers for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit