Skip to content
Laskyr

Plugins · custom-layouts · data as of 2026-11-04

Is Custom Layouts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.5.0 or newer fixes all of them that state a fix.

Latest version
1.5.1
Last updated
2025-12-29
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Build a list or grid layout of any post type (posts, products, pages + more). — by Code Amp

What to do

  1. Update to the latest version (1.5.1). Anything older than 1.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-layouts --field=version shows what you run; wp plugin update custom-layouts updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-62996 · published 2025-12-09

Missing authorization check in Custom Layouts (1.4.12 and older)

Affected
1.4.12 and older
Fixed in
1.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Code Amp Custom Layouts – Post + Product grids made easy custom-layouts allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Custom Layouts – Post + Product grids made easy: from n/a through <= 1.4.12.

NVD CVE-2025-62996Patchstack advisory

medium 6.5 CVE-2024-43305 · published 2024-08-18

Stored cross-site scripting (XSS) in Custom Layouts (1.4.11 and older)

Affected
1.4.11 and older
Fixed in
1.4.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Code Amp Custom Layouts – Post + Product grids made easy allows Stored XSS.This issue affects Custom Layouts – Post + Product grids made easy: from n/a through 1.4.11.

NVD CVE-2024-43305Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Layouts vulnerability status badge
<a href="https://laskyr.com/plugins/custom-layouts"><img src="https://laskyr.com/plugins/custom-layouts/badge.svg" alt="Custom Layouts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit