Skip to content
Laskyr

Plugins · custom-fonts · data as of 2026-11-01

Is Custom Fonts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.17)

As of 2026-11-01. 2 issues are on record for older versions; version 2.1.17 or newer fixes all of them that state a fix.

Latest version
2.1.17
Last updated
2026-08-24
Active installs
400,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Custom Fonts is a powerful WordPress plugin that allows you to upload your own custom fonts or choose from a vast collection of Google Fonts, all host … — by Brainstorm Force

What to do

  1. Update to the latest version (2.1.17). Anything older than 2.1.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-fonts --field=version shows what you run; wp plugin update custom-fonts updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-14351 · published 2026-01-20

Missing authorization check in Custom Fonts (2.1.16 and older)

Affected
2.1.16 and older
Fixed in
2.1.17 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Custom Fonts – Host Your Fonts Locally plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'BCF_Google_Fonts_Compatibility' class constructor function in all versions up to, and including, 2.1.16. This makes it possible for unauthenticated attackers to delete font directory and rewrite theme.json file.

NVD CVE-2025-14351Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-1332 · published 2024-05-24

Stored cross-site scripting (XSS) in Custom Fonts (2.1.4 and older)

Affected
2.1.4 and older
Fixed in
2.1.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Custom Fonts – Host Your Fonts Locally plugin for WordPress is vulnerable to Stored Cross-Site Scripting via svg file upload in all versions up to, and including, 2.1.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author level or higher, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-1332Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Fonts vulnerability status badge
<a href="https://laskyr.com/plugins/custom-fonts"><img src="https://laskyr.com/plugins/custom-fonts/badge.svg" alt="Custom Fonts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit