Skip to content
Laskyr

Plugins · custom-css-js · data as of 2026-11-01

Is Simple Custom CSS and JS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.54.3)

As of 2026-11-01. 1 issue is on record for older versions; version 3.4 or newer fixes all of them that state a fix.

Latest version
3.54.3
Last updated
2026-10-08
Active installs
600,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2.4+

Easily add Custom CSS or JS to your website with an awesome editor. — by SilkyPress

What to do

  1. Update to the latest version (3.54.3). Anything older than 3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-css-js --field=version shows what you run; wp plugin update custom-css-js updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2017-2285 · published 2017-08-02

Cross-site scripting (XSS) in Simple Custom CSS and JS (1.0 only, 1.1 only, 1.2 only, 1.3 only, 1.4 only, 1.5 only, 1.6 only, 2.0 only, 2.1 only, 2.2 only, 2.3 only, 2.4 only, 2.5 only, 2.6 only, 2.7 only, 2.8 only, 2.9 only, 2.10 only, 3.0 only, 3.1 only, 3.2 only, 3.3 only)

Affected
1.0 only, 1.1 only, 1.2 only, 1.3 only, 1.4 only, 1.5 only, 1.6 only, 2.0 only, 2.1 only, 2.2 only, 2.3 only, 2.4 only, 2.5 only, 2.6 only, 2.7 only, 2.8 only, 2.9 only, 2.10 only, 3.0 only, 3.1 only, 3.2 only, 3.3 only
Fixed in
3.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by CISA ADP
Details from the advisory

Cross-site scripting vulnerability in Simple Custom CSS and JS prior to version 3.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

NVD CVE-2017-2285Code change (fix)wordpress.orgjvn.jpwpvulndb.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Custom CSS and JS vulnerability status badge
<a href="https://laskyr.com/plugins/custom-css-js"><img src="https://laskyr.com/plugins/custom-css-js/badge.svg" alt="Simple Custom CSS and JS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit