Skip to content
Laskyr

Plugins · custom-contact-forms · data as of 2026-11-04

Is Custom Contact Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.20.0)

As of 2026-11-04. 1 issue is on record for older versions; version 7.16.1 or newer fixes all of them that state a fix.

Latest version
7.20.0
Last updated
2026-11-03
Active installs
6,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build powerful custom forms with drag and drop. Saved entries, dashboard, signatures, Mailchimp, webhooks, and modern spam protection. — by outlawgt

What to do

  1. Update to the latest version (7.20.0). Anything older than 7.16.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-contact-forms --field=version shows what you run; wp plugin update custom-contact-forms updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-75018 · published 2026-09-05

Missing authorization check in Custom Contact Forms (7.16 and older)

Affected
7.16 and older
Fixed in
7.16.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Custom Contact Forms plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 7.16. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with contributor-level access and above, to permanently force-delete arbitrary posts of any post type (including pages, administrator-authored posts, and WooCommerce products) and write arbitrary ccf_field_* post meta onto any post regardless of ownership or post type. The top-level form ID is checked via edit_post/publish_posts, but the nested fields[].ID and choices[].ID paths processed by _create_and_map_fields() and _create_and_map_choices() carry no equivalent capability or post-type guard, leaving those sinks fully exposed while delete_item() and delete_submission() contain explicit post-type restriction fixes demonstrating the developer's awareness of scoping requirements.

NVD CVE-2026-75018Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Contact Forms vulnerability status badge
<a href="https://laskyr.com/plugins/custom-contact-forms"><img src="https://laskyr.com/plugins/custom-contact-forms/badge.svg" alt="Custom Contact Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit