Skip to content
Laskyr

Plugins · custom-background-changer · data as of 2026-11-04

Is Custom Background Changer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0)

As of 2026-11-04. 1 issue is on record for older versions; version 4.0 or newer fixes all of them that state a fix.

Latest version
4.0
Last updated
2026-07-09
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Set a unique background color, gradient, image, overlay, or video for any individual post or page — all from a single elegant meta box. — by Anshul Gangrade

What to do

  1. Update to the latest version (4.0). Anything older than 4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get custom-background-changer --field=version shows what you run; wp plugin update custom-background-changer updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62125 · published 2025-12-31

Stored cross-site scripting (XSS) in Custom Background Changer (3.0 and older)

Affected
3.0 and older
Fixed in
4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Anshul Gangrade Custom Background Changer custom-background-changer allows Stored XSS.This issue affects Custom Background Changer: from n/a through <= 3.0.

NVD CVE-2025-62125Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Custom Background Changer vulnerability status badge
<a href="https://laskyr.com/plugins/custom-background-changer"><img src="https://laskyr.com/plugins/custom-background-changer/badge.svg" alt="Custom Background Changer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit