Skip to content
Laskyr

Plugins · curatorio · data as of 2026-11-04

Is Curator.io safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.9.6 or newer fixes all of them that state a fix.

Latest version
1.9.7
Last updated
2026-09-02
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Aggregate and embed your social media posts on your site (Facebook, Twitter, Instagram, Pinterest and many more) as a beautiful social media feed. — by Curator.io

What to do

  1. Update to the latest version (1.9.7). Anything older than 1.9.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get curatorio --field=version shows what you run; wp plugin update curatorio updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62742 · published 2025-12-31

Stored cross-site scripting (XSS) in Curator.io (1.9.5 and older)

Affected
1.9.5 and older
Fixed in
1.9.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Curator.io Curator.io curatorio allows Stored XSS.This issue affects Curator.io: from n/a through <= 1.9.5.

NVD CVE-2025-62742Patchstack advisory

medium 5.4 CVE-2024-9057 · published 2024-10-10

Stored cross-site scripting (XSS) in Curator.io (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Curator.io: Show all your social media posts in a beautiful feed. plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘feed_id’ attribute in all versions up to, and including, 1.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9057Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Curator.io vulnerability status badge
<a href="https://laskyr.com/plugins/curatorio"><img src="https://laskyr.com/plugins/curatorio/badge.svg" alt="Curator.io vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit