Skip to content
Laskyr

Plugins · css-javascript-toolbox · data as of 2026-11-04

Is CSS & JavaScript Toolbox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (12.0.7)

As of 2026-11-04. 5 issues are on record for older versions; version 12.0.7 or newer fixes all of them that state a fix.

Latest version
12.0.7
Last updated
2026-08-26
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4.0+

Add CSS, JavaScript, PHP and HTML code snippets to your site. — by wipeoutmedia

What to do

  1. Update to the latest version (12.0.7). Anything older than 12.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get css-javascript-toolbox --field=version shows what you run; wp plugin update css-javascript-toolbox updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14814 · published 2026-09-25

Stored cross-site scripting (XSS) in CSS & JavaScript Toolbox (12.0.6 and older)

Affected
12.0.6 and older
Fixed in
12.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CSS & JavaScript Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's cjtoolbox shortcode in all versions up to, and including, 12.0.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14814Wordfence advisoryCode change (fix)

medium 4.4 CVE-2025-13533 · published 2026-09-18

Stored cross-site scripting (XSS) in CSS & JavaScript Toolbox (12.0.6 and older)

Affected
12.0.6 and older
Fixed in
12.0.7 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CSS & JavaScript Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 12.0.6 via the Assignment Engine fields. This is due to insufficient input sanitization and output escaping on assignment data fields including Expressions, URLs, and Advanced assignment data. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the CJT block edit screen in the admin dashboard.

NVD CVE-2025-13533Wordfence advisoryCode change (fix)gist.github.comPlugin source

medium 4.4 CVE-2025-11928 · published 2025-11-01

Stored cross-site scripting (XSS) in CSS & JavaScript Toolbox (12.0.5 and older)

Affected
12.0.5 and older
Fixed in
12.0.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CSS & JavaScript Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 12.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-11928Wordfence advisoryCode change (fix)

high 7.5 CVE-2025-3703 · published 2025-08-14

File inclusion in CSS & JavaScript Toolbox (12.0.3 and older)

Affected
12.0.3 and older
Fixed in
12.0.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in wipeoutmedia CSS & JavaScript Toolbox css-javascript-toolbox allows PHP Local File Inclusion.This issue affects CSS & JavaScript Toolbox: from n/a through < 12.0.3.

NVD CVE-2025-3703Patchstack advisory

medium 5.4 CVE-2023-50823 · published 2023-12-21

Stored cross-site scripting (XSS) in CSS & JavaScript Toolbox (11.7 and older)

Affected
11.7 and older
Fixed in
11.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wipeout Media CSS & JavaScript Toolbox allows Stored XSS.This issue affects CSS & JavaScript Toolbox: from n/a through 11.7.

NVD CVE-2023-50823Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CSS & JavaScript Toolbox vulnerability status badge
<a href="https://laskyr.com/plugins/css-javascript-toolbox"><img src="https://laskyr.com/plugins/css-javascript-toolbox/badge.svg" alt="CSS & JavaScript Toolbox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit