Skip to content
Laskyr

Plugins · cryptx · data as of 2026-11-04

Is CryptX safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2.1)

As of 2026-11-04. 1 issue is on record for older versions; version 4.0.6 or newer fixes all of them that state a fix.

Latest version
4.2.1
Last updated
2026-09-11
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

No more SPAM by spiders scanning your site for email addresses! — by Ralf Weber

What to do

  1. Update to the latest version (4.2.1). Anything older than 4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cryptx --field=version shows what you run; wp plugin update cryptx updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-13739 · published 2025-12-05

Stored cross-site scripting (XSS) in CryptX (4.0.5 and older)

Affected
4.0.5 and older
Fixed in
4.0.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CryptX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `cryptx` shortcode in all versions up to, and including, 4.0.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13739Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CryptX vulnerability status badge
<a href="https://laskyr.com/plugins/cryptx"><img src="https://laskyr.com/plugins/cryptx/badge.svg" alt="CryptX vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit