Plugins · crypto · data as of 2026-11-04
Is Crypto safe? Known vulnerabilities and latest version
- Latest version
- 3.0.4
- Last updated
- 2026-07-27
- Active installs
- 10+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.6+
Live crypto prices via DScroll or CoinMarketCap. No API key required. Display using shortcode, Gutenberg block, or Elementor widget. — by odude
What to do
- Update to the latest version (3.0.4). Anything older than 2.151 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get crypto --field=version shows what you run; wp plugin update crypto updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-11986 · published 2025-11-11
Information disclosure in Crypto (2.22 and older)
- Affected
- 2.22 and older
- Fixed in
- 2.151 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Crypto plugin for WordPress is vulnerable to Information exposure in all versions up to, and including, 2.22. This is due to the plugin registering an unauthenticated AJAX action (wp_ajax_nopriv_crypto_connect_ajax_process) that allows calling the register and savenft methods with only a publicly-available nonce check and no wallet signature verification. This makes it possible for unauthenticated attackers to set a site-wide global authentication state via a single transient, bypassing all access controls for ALL visitors to the site. The impact is complete bypass of [crypto-block] shortcode restrictions and page-level access controls, affecting all site visitors for one hour, plus the ability to inject arbitrary data into the plugin's custom_users table.
medium 5.3 CVE-2025-11988 · published 2025-11-11
Denial of service in Crypto (2.22 and older)
- Affected
- 2.22 and older
- Fixed in
- 2.151 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Crypto plugin for WordPress is vulnerable to unauthorized manipulation of data in all versions up to, and including, 2.22. This is due to the plugin registering an unauthenticated AJAX action (wp_ajax_nopriv_crypto_connect_ajax_process) that allows calling the crypto_delete_json method with only a publicly-available nonce check. This makes it possible for unauthenticated attackers to delete specific JSON files matching the pattern *_pending.json within the wp-content/uploads/yak/ directory, causing data loss and denial of service for plugin workflows that rely on these artifacts.
critical 9.8 CVE-2024-9988 · published 2024-10-29
Authentication bypass in Crypto (2.19 and older)
- Affected
- 2.19 and older
- Fixed in
- 2.20 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Crypto plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.19. This is due to missing validation on the user being supplied in the 'crypto_connect_ajax_process::register' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the username.
NVD CVE-2024-9988Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2024-9989 · published 2024-10-29
Authentication bypass in Crypto (2.18 and older)
- Affected
- 2.18 and older
- Fixed in
- 2.19 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Crypto plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.18. This is due to a limited arbitrary method call to 'crypto_connect_ajax_process::log_in' function in the 'crypto_connect_ajax_process' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the username.
NVD CVE-2024-9989Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2024-9990 · published 2024-10-29
Cross-site request forgery (CSRF) in Crypto (2.15 and older)
- Affected
- 2.15 and older
- Fixed in
- 2.16 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Crypto plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.15. This is due to missing nonce validation in the 'crypto_connect_ajax_process::check' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2024-9990Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-07-27 — latest release on wordpress.org (3.0.4).
- 2025-11-11 — Information disclosure disclosed (CVE-2025-11986), fixed in 2.151.
- 2025-11-11 — Denial of service disclosed (CVE-2025-11988), fixed in 2.151.
- 2024-10-29 — Authentication bypass disclosed (CVE-2024-9988), fixed in 2.20.
Get an email when Crypto has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Crypto (crypto) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Authentication bypass (2) · Sensitive data exposure (1) · Denial of service (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/crypto (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/crypto"><img src="https://laskyr.com/plugins/crypto/badge.svg" alt="Crypto vulnerability status"></a>