Skip to content
Laskyr

Plugins · cryout-serious-slider · data as of 2026-11-04

Is Serious Slider safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.2)

As of 2026-11-04. 5 issues are on record for older versions; version 1.4.1 or newer fixes all of them that state a fix.

Latest version
1.4.2
Last updated
2026-10-05
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Serious Slider is a free highly efficient SEO friendly fully translatable accessibility ready image slider for WordPress. Seriously! — by CryoutCreations

What to do

  1. Update to the latest version (1.4.2). Anything older than 1.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cryout-serious-slider --field=version shows what you run; wp plugin update cryout-serious-slider updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-15726 · published 2026-08-16

Stored cross-site scripting (XSS) in Serious Slider (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Serious Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'theme' Shortcode Attribute in all versions up to, and including, 1.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-15726Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-25399 · published 2026-02-19

Missing authorization check in Serious Slider (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CryoutCreations Serious Slider cryout-serious-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Serious Slider: from n/a through <= 1.2.7.

NVD CVE-2026-25399Patchstack advisory

medium 5.4 CVE-2024-11108 · published 2024-12-20

Stored cross-site scripting (XSS) in Serious Slider (older than 1.2.7)

Affected
older than 1.2.7
Fixed in
1.2.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Serious Slider WordPress plugin before 1.2.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2024-11108WPScan advisory

medium 5.4 CVE-2024-35762 · published 2024-06-21

Stored cross-site scripting (XSS) in Serious Slider (1.2.4 and older)

Affected
1.2.4 and older
Fixed in
1.2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Cryout Creations Serious Slider allows Stored XSS.This issue affects Serious Slider: from n/a through 1.2.4.

NVD CVE-2024-35762Patchstack advisory

medium 4.3 CVE-2024-33650 · published 2024-04-26

Cross-site request forgery (CSRF) in Serious Slider (1.2.4 and older)

Affected
1.2.4 and older
Fixed in
1.2.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Cryout Creations Serious Slider.This issue affects Serious Slider: from n/a through 1.2.4.

NVD CVE-2024-33650Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Serious Slider vulnerability status badge
<a href="https://laskyr.com/plugins/cryout-serious-slider"><img src="https://laskyr.com/plugins/cryout-serious-slider/badge.svg" alt="Serious Slider vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit